Wolters Kluwer Account delay in sending notifications

Incident Report for Wolters Kluwer UK

Monitoring

We are currently monitoring the issue where there are delays with the MFA notifications being sent from Wolters Kluwer Account.
Posted Apr 03, 2025 - 14:56 BST

Investigating

We are currently investigating an issue where there are delays with the MFA notifications being sent from Wolters Kluwer Account.

This will affect users logging in to any cloud application where they have MFA configured to send them an email, where they use the Forgotten Password function, and where admin users are sending invitations to colleagues (or clients for CCH OneClick).

This is being investigated and a further update will be posted at 15:00.
Posted Apr 03, 2025 - 13:30 BST
This incident affects: Wolters Kluwer Account (login functionality).