Wolters Kluwer Account - Log in issues

Incident Report for Wolters Kluwer UK

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:39 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:24 GMT

Update

Access to CCH iFirm and CCH OneClick are currently impacted by an issue with a third-party provider. We’re in contact with them and will share updates as soon as possible. Thank you for your patience.
Posted Dec 05, 2025 - 09:13 GMT

Investigating

We are currently aware of an issue accessing our applications via Wolters Kluwer Account. We are investigating the issue and will provide a further update by 10:00
Posted Dec 05, 2025 - 09:05 GMT
This incident affected: Wolters Kluwer Account (login functionality).