Issue with launching new clients in CCH iFirm

Incident Report for Wolters Kluwer UK

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 10:41 BST

Update

The issue has been resolved, clients launched from CCH Central are now created successfully in CCH iFirm.
Posted Sep 30, 2025 - 08:28 BST

Identified

We are currently taking steps to resolve an issue in CCH iFirm which is preventing new clients from being created in CCH iFirm when launched from CCH Central. Accessing existing clients in CCH iFirm continues to perform normally. A further update will be provided before 16:00.
Posted Sep 29, 2025 - 13:43 BST

Investigating

We are currently investigating an issue in CCH iFirm which is preventing new clients from being created in CCH iFirm when launched from CCH Central. Accessing existing clients in CCH iFirm continues to perform normally. A further update will be provided before 14:00.
Posted Sep 29, 2025 - 12:06 BST
This incident affected: CCH iFirm (CCH iFirm AML, CCH iFirm Validate, CCH iFirm Accounts Production, CCH iFirm Personal Tax, CCH iFirm MTDfIT (Making Tax Digital for Income Tax), CCH iFirm Other).