A solution for this issue has been implemented and our teams will continue to monitor closely for the remainder of the day.
Posted Oct 09, 2025 - 12:59 BST
Identified
We are investigating an intermittent issue which may prevent certain CCH iFirm applications from loading correctly in your web browser. If you are experiencing any unusual behaviour when accessing CCH iFirm, please retry again later.
A further update will be given by 13:00
Posted Oct 09, 2025 - 12:04 BST
Investigating
We are investigating an intermittent issue which may prevent certain CCH iFirm applications from loading correctly in your web browser. If you are experiencing any unusual behaviour when accessing CCH iFirm, please retry again later.
A further update will be given by 12:30.
Posted Oct 09, 2025 - 10:42 BST
This incident affected: CCH iFirm (CCH iFirm AML, CCH iFirm Validate, CCH iFirm Accounts Production, CCH iFirm Personal Tax, CCH iFirm MTDfIT (Making Tax Digital for Income Tax), CCH iFirm Other).